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ABSTRACT OF THESIS

BUILDING WEB-BASED INTERACTIVE KEYS
TO THE HYMENOPTERAN FAMILIES AND SUPERFAMILIES
Linear keys are the standard for identification in insect taxonomy. However, with the use
of the world wide web and non-linear key formats, a variety of key architectures are now
available for creating pleasing and informative keys for wide-spread use. This project uses
DELTA (Description Language for Taxonomy), created by the CSIRO Division of Entomology,
to produce a non-linear key to the Hymenoptera. A variety of tools for illustrating
morphological characters were implemented to clarify the key characters and the keys are
intergrated into the National Science Foundation’s “Assembling the Tree of Life” initiative for
the Hymenoptera.
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DEDICATION
Cassius

Antony, The posture of your blows are yet unknown;
But for your words, they rob the Hybla bees,
And leave them honeyless.

Antony

Not stingless too.

Brutus

O, yes, and soundless too;
For you have stol'n their buzzing, Antony,
And very wisely threat before you sting.

---From Act V, Scene I Julius Caesar by William Shakespeare
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Chapter 1: Introduction

Computer Terminology
Throughout this thesis computer related terminology is formatted differently than the
body of the text to clarify the function of the term. All file names are in single quotes (i.e.
‘specs’), interactive key program names are in all capitals (i.e. DELTA), commands initiated
from the program menu bar are underlined (i.e. file>find file), formal names and direct quotes
from individuals or from the Hymenoptera Interactive Key are placed in quotations (i.e. “Do the
antenna sit on a shelf?”), program windows and fields are in bold lettering (i.e. Item edit
window), and titles of publications and manuals are italicized (i.e. Hymenoptera of Costa Rica).
A window is defined as an interface contained within a program for adding information to the
program. A field is the actual location on the window in which information is added and a tab is
button on a window that links to a new window. Figure 1-1 illustrates a window, the Character
Edit window, which contains three fields and the five standard tabs.
Figure 1-1: Computer related terminology
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Hymenoptera Biodiversity
Hymenoptera is one of the three largest orders of insects. We recognize twenty
superfamilies and eighty-nine extant families, with an estimated total of 300,000 species
worldwide (Goulet & Huber, 1993). Evidence suggests that the Hymenoptera is the most
species-rich group in temperate regions (Gaston, 1991) and there are more species in the
parasitoid family Ichneumonidae than the combination of all mammal and bird species (Wilson,
1988; Gaston, 1993). The order is exceptionally diverse: from thumb sized Vespidae that
provision their young with larvae of crop pests, wingless Chrysididae egg parasitoids, to dustsized Mymaridae commonly called “fairy-flies” due to their feather-like wings. Although this
diversity is often overlooked, the common names ant, bee, sawfly, and wasp indicate the
importance of Hymenoptera in our society (Gauld and Bolton, 1988). Arguably the order is best
known for the few social families that contain many individuals; encountered as a result of their
ability to sting, bite, and infest houses. They are useful to us as biological control agents, primary
pollinators for food production, and forest decomposers.
However a person regards the members of the Hymenoptera, either as pests, assets or
curiosities, it is essential to identify them. Identification keys to the order are almost as diverse
as the Hymenoptera themselves. A key is defined as “a taxonomic device by which objects are
identified based on suites of characters or character states” (Gordh & Headrick, 2001). They
exist in multiple formats including pictorial keys, interactive keys and dichotomous keys.
Pictorial keys have a habitus image coinciding with a taxonomic name, such as Borror & White’s
(1970) Peterson’s Field Guide to Insects. Dichotomous keys are
“a device of logic used in taxonomy to identify taxa. Specifically, dichotomous keys
consist of statements about characters or character states which are provided in
alternative contrasting statements arranged in couplets. Based on the correctness of the
statement with regard to the specimen at hand, the user is directed to other contrasting
statements and ultimately the name of the taxon” (Gordh & Headrick, 2001).
Unlike dichotomous keys, interactive keys are non-linear. The user, defined as any individual
identifying a specimen using an interactive key, may choose any character from a list of
characters. These characters correspond to an exhaustive list of taxa, and taxa are removed from
the list as character states are selected. Pictorial keys and dichotomous keys are traditionally
found in print format where interactive keys exist only as computer programs. Besides being
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more efficient, interactive keys have many advantages over traditional dichotomous keys. They
are easy to update, can be distributed over the internet, and may contain full color images at low
cost; vastly different from the high cost of printing with color illustrations.
Interactive keys, first termed polyclave keys, were developed around 1969 with Hansen
and Rahn’s, Determination of angiosperm families by means of a punched-card system (Johnson,
1980). These early keys were all hand punched; a laborious process, limiting their production
(Johnson, 1980). In 1974, Morse created the first matrix-generated polyclave program called
CARDKEY. Polyclaves that use a combination of character state choices began in 1975. This
form of polyclave allowed for more character choices and more detailed keys (Pankhurst et al,
1975). INTKEY, the interactive key used to create the Hymenoptera family keys presented in
this thesis, was developed in 1993. Version 4.00, for MS-Windows, was released in May 1995.
The present version, 5.11, was released in December 2000 (Dallwitz et al., 2000). LUCID, an
interactive key similar to INTKEY, was developed by the Cooperative Research Centre for
Tropical Pest Management (CTPM) and the Department of Entomology at the University of
Queensland in 1997 (Taxacom Listserv Archive for 1997: LucID interactive key software).
INTKEY and LUCID are the current standards for interactive keys. I chose INTKEY to produce
the Hymenoptera Interactive Key because of its widespread use.
Hymenoptera Family-Level Keys
The majority of available Hymenoptera keys are either specific to a subset of the order or
to a particular geographic location. There are only a few dichotomous keys to the families for
the entire order Hymenoptera: Brues et al. (1954), Handlirsch (1925), Borror and Delong’s
Introduction to the Study of Insects (2004), and Mason’s (1993) key in Goulet and Huber’s,
Hymenoptera of the World. In the valuable dichotomous key in the Hymenoptera of Costa Rica,
edited by Paul Hanson and Ian Gould (1995), 61 of the recognized 89 families were included in
the book due to their presence in the region. Most interactive keys to members of the
Hymenoptera deal with taxonomic groups that a particular lab or researcher is working, with one
notable exception. The British Insects: Families of Hymenoptera created by L. Watson and M.J.
Dallwitz (http://delta-intkey.com/britin/hym/, 2003) contains 55 families. Illustrations in the key
come from historically valuable volumes of British Insects: illustrations and descriptions of the
genera of insects found in Great Britain and Ireland (1824-1840), but they lack detail.

3

Hymenoptera Phylogeny
Printed dichotomous keys are static, reflecting a phylogenetic hypothesis at the time of
publication. Interactive keys, being web based, can be updated rapidly, allowing for access to
recent information. Unresolved phylogenies often result in keys that may not have characters to
elucidate a family, or keys that require a large number of characters to separate exceptional taxa.
As these problems are resolved it is important to incorporate them into identification keys
without waiting years for the next edition of a book. Within the Hymenoptera, potentially
polyphyletic superfamilies include the Evanioidea and Proctotrupoidea, and of the hymenopteran
families presently recognized, 20 may not be monophyletic. These include the Agaonidae,
Andrenidae, Aphelinidae, Argidae, Aulacidae, Colletidae, Diapriidae, Megaspilidae, Melittidae,
Pergidae, Perilampidae, Proctotrupidae, Pteromalidae, Roproniidae, Scelionidae, Tenthredinidae,
Tetracampidae, Torymidae, Xyelidae and Tanaostigmatidae (Sharkey, NSF Proposal). Eight of
these families belong to the Chalcidoidea, and for this reason it only included in the
Hymenoptera Family Key to superfamily level.
Carl von Linne´ (1735), in the Systema Naturae, established the class Insecta and first
recognized categorically the division between the stinging bees and the parasitic wasps. He
termed the stinging organisms Apis, Bombylius, Vespa and Crabro, and the parasitic wasps were
all clumped together in one group, Ichneumon. Today the stinging Hymenoptera are placed in an
informal grouping known as the Aculeata and the non-stinging forms into the Parasitica, together
these two groups compose the monophyletic group Apocrita. Apocrita are distinguished from
the basal lineages of the Hymenoptera, or Symphyta, by the possession of the “wasp-waist”
(Mason and Huber, 1993). This narrow constriction between the propodeum and the second
abdominal segment allows for great range of motion for the metasoma Symphytan phylogeny at
the family level is mostly resolved, through research by Lars Vilhelmsen (2001) and Susanne
Schulmeister (2003). The parasitic Orussoidea are supported as the sister-group of the Apocrita
(Rasnitsyn, 1988).
A. P. Rasnitsyn and E. Koenigsmann (Koenigsmann 1976, Rasnitsyn 1969, 1980, 1988)
conducted the first attempts looking at the entire order with a series of papers. Rasnitsyn (1988)
remained the foundation of all subsequent analysis until 1999 when Fredrick Ronquist et al.
published a reanalysis of the Rasnitsyn (1988) paper. The reanalysis included the characters that
Rasnitsyn used but did not incorporate those published after 1988 (Sharkey, NSF proposal).
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Sharkey and Roy (2002) critically reanalyzed and recoded the wing characters from the Ronquist
et al (1999) paper and showed how the original phylogenetic hypothesis was dependent on
incorrectly coded wing characters. While results supported traditionally well-known
relationships in the Parasitica, the monophyly of the Ichneumonidae + Braconidae, Ibaliidae +
Figitidae + Cynipidae, Megaspilidae + Ceraphronidae and Chalcidoidea + Mymarommatidae,
these works illustrate how little is known about apocritan relationships at the family level (figure
1-2).
Figure 1-2: Hymenoptera phylogeny from Sharkey and Roy, 2002

Among the Aculeate Hymenopteran, Chrysidoidea, Apoidea and Vespoidea, the
superfamily relationships are well resolved. The family limits within the Chrysidoidea are
supported. The Pompilidae are generally considered to belong to the Vespoidea; however, their
placement is not resolved within the superfamily. Morphological indications even suggest that
they may belong to the Apoidea (Brothers and Carpenter, 1993). Although the monophyly is
fairly well supported, the family-level relationships in the Apoidea are largely unresolved. In one
of the most recent phylogenetic studies the Sternotritidae and Melittidae appear in multiple
places within the tree (Brothers, 1993) and the family-level relationships among the specoid
wasps are debated. Melo (1997) recognized five families of Apoidea: Ampulicidae, Apidae,
Crabronidae, Specidae and Heterogynidae. This resolved the superfamily by placing all bees into
the family Apoidea. Michener (2000), presently considered the leading authority on bees, splits
5

the Apoidea into ten families: Sternotritidae, Colletidae, Andrenidae, Halictidae, Melittidae,
Megachilidae, Apidae, Sphecidae, Crabronidae and Ampulicidae.
Objective of Hymenoptera Family Keys
The objective of this project is to create an easily updatable interactive key to the
hymenopteran families, excluding the families of Chalcidoidea. The key is intended for
distribution through the Hymenoptera Assembling the Tree of Life (HymAToL) web site, a
National Science Foundation funded initiative to discover the phylogeny of all known life. The
goal is to appeal to a wide range of users, stimulating interest in HymAToL and the megabiodiverse order Hymenoptera.
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Chapter II. Methodology

Organization of Hymenoptera Interactive Keys on the Internet
The Hymenoptera Interactive Keys were organized into a total of eleven separate
superfamily and family level keys (figure 2-1). The ‘Index.html’ web page contains links to
each of the eleven keys individually, a link to the DELTA program page, and a brief outline of
the keys contained within the pages. A novice user who is not able to identify a specimen to
superfamily may begin with the Superfamily Key. This key contains all of the one-family
superfamilies: Megalyroidea, Trigonalyoidea, Stephanoidea and Mymarommatoidea, as well as
the multifamily superfamilies: Evanioidea, Ceraphronoidea, Proctotrupoidea, Platygastroidea,
Cynipoidea, Chalcidoidea, Ichneumonoidea, Chrysidoidea, Apoidea and Vespoidea. The
Superfamily Key groups all of the superfamilies of the Symphyta, an informal assemblage of the
basal hymenopteran lineages, into a single key. Although the symphytan section of the
Hymenoptera Interactive Key contains seven separate superfamilies: Xyeloidea, Pamphilioidea,
Tenthredinoidea, Cephoidea, Siricoidea, Xiphydrioidea and Orussoidea, they share similar
morphological features and are often considered together by taxonomists when investigating the
morphology, taxonomy, and phylogeny of the order.
Figure 2-1: Organization of Hymenoptera Interactive Keys on the internet
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The justification for having multiple keys instead of one single oversized key is that
characters are often useful for only specific taxon. Including all such characters in a
comprehensive key would force users to wade through a large number of inefficient characters to
arrive at identification. If all characters informative only for individual families were included in
one key, the key would be hundreds of characters long. For example, an enlarged midtibial spur
is diagnostic for Ctenoplectrini (Apidae). When a key user is trying to identify a specimen
known to be a member of the superfamily Apoidea, this spur character may result in a quick
identification. However, the character “Does the specimen have an enlarged midtibial spur” is
not informative for the majority of the Hymenopteran families. A second advantage to
separating keys based on superfamilies is that partially informed users can limit their search
simply by going to the key closest to the identification. For example, if the user knows that their
specimen is a bee, they can proceed immediately to the Apoidea key.
DELTA (DEscription Language for Taxonomy)
Description Language for Taxonomy, or DELTA, was created at the Commonwealth
Scientific and Industrial Research Organization (CSIRO) between 1971 and 2000. DELTA is a
taxonomic organizational tool, allowing the author to enter characters, character states, and taxa
into an easily readable matrix format. The program is designed for Windows 95 or later and also
works in Virtual PC for Macintosh.
The process of creating an interactive key using the DELTA taxonomic data format
began with entering the characters and taxa in a DELTA matrix. Information about the type of
character, reliability of the character, notes concerning the character, illustrations of taxa,
character states, and character dependences were entered.
Once data are entered into DELTA, the program CONFOR can translate the information
into multiple formats, including: NEXUS, natural language lists of characters, non-linear keys
(INTKEY) or traditional dichotomous keys. CONFOR translates the directive files created by
the DELTA program. In order for CONFOR to run, the author must first export the directives as
text files and then run the “Action Sets” dialogue from the menu contained inside DELTA,
which informs CONFOR which translation from the directives is desired. From this dialogue,
CONFOR creates specific directive files for use by other programs such as INTKEY. These
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directive files are the program’s organizational system, where tasks are compartmentalized into
separate files with ‘.ink,’ ‘.bak’ or ‘.ini’ extensions. When translating to the INTKEY format,
CONFOR creates the ‘toint’ file and the ‘intkey.ink’ file which are the directive files for running
an interactive key. The three primary output files for DELTA and CONFOR are the ‘chars’,
‘items’ and ‘specs’ files. The ‘chars’ file is composed of the list of characters found in the
DELTA matrix, the ‘items’ file lists the taxa, and the ‘specs’ file dictates how the ‘chars’ and
‘items’ files are arranged in the matrix (Dallwitz et al., 1995 onward).
The directive files were manipulated using the Attribute Editor (Trees) window (figure
2-3); however, it was often helpful to manipulate the directive files directly with Notepad© for
Windows operating systems. Manipulated directive files were imported as text files and then
saved as non-extension files, replacing the original directive files. If an original directive file and
a text file are both present in the directive folder, the program will read the original, not the
updated file. For example, if the ‘specs’ file is saved as a ‘specs.txt’ file, CONFOR will read the
directive file listed simply as ‘specs’ without the ‘.txt’ extension.
Using DELTA to Create INTKEY
Organization of the sixty plus directive files was addressed before using DELTA. All of
the directive files were placed in a single folder. This folder was labeled “directive,” and existed
inside a larger folder labeled for the title of the specific interactive key. A separate file for the
images used in the key was created inside the directives file. This became increasingly important
as the key expanded and the number of image files increased. The program requires that all
image files be contained in the same folder. The initiation file for the DELTA program, or ‘.dlt’
file, was placed outside of the directives folder, which proved useful in locating the file.
Additional directive files that were manipulated using Notepad© were backed up in a separate
folder outside of the directives file. When DELTA translates “Action Sets” using CONFOR,
specific directives may be changed back to the program’s default setting. These directives
include the ‘contents.ind’ file for manipulating references and acknowledgments, and the
‘toolbar.inp’ file which indicates button function.
INTKEY is one of the possible translations of the DELTA matrix using CONFOR.
Recognizing the purpose of the original matrix is helpful in making decisions when entering data
into the matrix. Brackets are used around the character that will be replaced in the final
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description by the character state (Dallwitz et.al, 1993). For example, a character that is entered
as “ integument <color>” with character states “blue or blue absent” will be translated into the
final description as “integument blue” as the question of color is replaced by the state blue
(figure 2-2). However, a character written in the manner “integument <color>” is not a typical
way an individual encounters a question. Generally, when a question is addressed it is in the
form of a complete sentence such as, “Is the integument blue?” with character state choice as
“yes or no.” Character state descriptions resulting from a character state written in the form of a
complete sentence do not read as well as the bracketed character descriptions. The description
resulting from the sentence “Is the integument blue?” with state choice “yes” results in the
confusing character state description “Is the integument blue?yes.”
Figure 2-2: Difference in final descriptions depending on the style of writing initial characters
Format of Character

Character State

Resulting Description

integument <color>

Blue

integument blue

Is the integument blue?

Yes

Is the integument blue?yes

The Hymenopteran Interactive Keys used complete sentences to enter the characters. Although
final descriptions may be jumbled these were not the objective of the present effort. If the
original intention of the project was to create taxon descriptions, the information would be
entered in DELTA using brackets.
Upon first opening the DELTA program, the author is directed to the Attribute Editor
(Trees) window in DELTA (figure 2-3), and may use this window as one of two windows to
code and view all of the characters and taxa in the program. The other window is the Attribute
Editor (Grid) window (figure 2-4). These windows may be interchanged as desired from the
menu View>Attribute Editor (Grid), or View>Attribute Editor (Trees), to enter data.
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Figure 2-3: Attribute Editor (Trees) window

Figure 2-4: Attribute Editor (Grid) window
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Creating a matrix was the natural first step in developing an INTKEY. Taxa and habitus
images were entered in the Item Edit window (figure 2-5). This window is accessed from the
menu, View>Taxon editor, or by double-clicking in the Taxon field from the Attribute Editor
(Trees) window. Each taxon has an associated number, which corresponds to its location on the
character tree or in the matrix.
Entered in the Subject text field (figure 2-5) were the descriptive names for the images
used in the final interactive key. Information concerning specific taxa was posted in the
Developers notes field concerning needed improvements, corrections, and observations. Once
the taxa had been entered, the Done button, in the bottom left hand corner, was clicked to close
the window.
Figure 2-5: Item Edit window in DELTA

Characters were entered in a similar fashion. The Character field in the Attribute
Editor (Trees) window is double clicked to open the Character Edit window (figure 2-6) or it
may be accessed from the menu View> Taxon editor.
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Figure 2-6: Character Edit window in DELTA

Characters and Coding the Matrix
DELTA supplies multiple coding options for character types including: unordered multistate, real numeric, integer numeric, ordered multistate, and text. The Hymenoptera Interactive
Key used only unordered multistate characters and integer numeric characters. Unordered
multistate characters are lists of several discrete choices from which the key user chooses the one
most appropriate for their unknown specimen. An example of an unordered multistate character
is, "Do the antenna appear to sit on an antennal shelf when viewed laterally?" with character
states “yes/no” (figure 3-6). Integer characters are counting numbers and are coded for the entire
range for the family. The user enters the number found on their specific specimen. An example
of an integer character is the number of antennal segments, or flagellomeres, found on the
antenna (figure 3-3).
The abilities of the eventual users of a key were considered when defining character
states. Each character state of an unordered multistate must be clear and distinctly separated from
other states. Taxa that contain a subtle version of the character state, or that contain both states
within the family, were coded “yes/no” for that character.
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Translating Characters from a Dichotomous Key to an Interactive Key
The Hymenoptera Interactive Keys were partly based on the 1993 dichotomous keys in
Hymenoptera of the World: an Identification Guide to Families, edited by Henri Goulet and John
Huber. Translating a dichotomous key into an interactive key creates challenges for coding.
Often dichotomous keys will rank multiple characters from the most informative to the least,
include characters that are only present in a few groups within a family, and include characters
that are relevant only for a few terminal taxa. Interactive keys allow the user to approach the
characters from any direction in the key, so each character must be self-contained and not
dependant on answering a prior character correctly. Also, dichotomous key characters beginning
with statements such as "many" or "a few" are not useful or necessary in interactive keys.
Unordered character states in an interactive key require that taxa with "a few" to be coded for
both presence and absence of that character, rendering them uninformative. For example, in the
Ichneumonoidea interactive key the vein 2m-cu is very useful for separating Ichneumonidae
from Braconidae, as the majority of ichneumonids have this vein and braconids generally do not.
One rare Braconidae, Apozyx penai, does have vein 2m-cu, so if the vein is present, you either
have an ichneumonid or a specimen of Apozyx penai. If this character were to be coded in the
interactive key matrix both states (present/absent) would be required for the Braconidae (figure
2-7).
Figure 2-7: Character matrix with Apozyx penai and most Braconidae combined
Is vein 2m-cu present?
Ichneumonidae

Present

Braconidae

Present or absent

To overcome this apparent disadvantage, Apozyx penai was separated in the taxon list,
leaving “Most Braconidae” for all of the braconids that do not contain vein 2m-cu. A second
character, “Cyclostome mouth?,” separates Apozyx penai easily from the Ichneumonidae. The
resulting matrix (figure 2-8) increases the effectiveness of this easily observed character, the 2mcu vein, because “Most Braconidae” may now be coded as “Absent” and all Ichneumonidae
“Present,” distinctly separating the two taxa.
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Figure 2-8: Character matrix with Apozyx penai and most Braconidae separated.
Is vein 2m-cu present?

Cyclostome mouth?

Ichneumonidae

Present

Absent

Apozyx penai

Present

Present

Braconidae
most Braconidae Absent

Present or absent

The keys are not intended to key every specimen of Hymenoptera in the world. If every rare and
exceptional species were included the keys would be long and cumbersome. The qualifying
condition of being common enough to separate out a taxon was somewhat arbitrary. Generally, a
taxon was considered common enough to be separated if a collector was likely to find a
specimen with a “moderate” amount of collecting. A taxon was not considered common enough
if it is “rarely” collected. These decisions were made with the aid of collaborators who have
extensive collecting experience within their area of taxonomic expertise. Taxa that were
exceedingly rare were only mentioned in the Notes section of the key and illustrated there with a
photograph.
Characters are ordered in INTKEY based on those characters with states that tend to
separate the greatest percent of the remaining taxa. Those that possess the ability to differentiate
50% of the remaining taxa are put at the top of the character list. Often Hymenoptera with
reduced wings have unusual morphological features, but these characters are usually only
important in separating these taxa from others with reduced wings. When all taxa are being
considered these characters are near the bottom of an exhaustive list of characters; however, after
selecting the “wings reduced or absent” state of the character “Are the wings fully developed?”
all characters associated with fully developed wings are removed and those characters that are
most efficient at separating taxa with wings reduced or absent move to the top of the list. Also,
in the Remaining Taxa field (figure 3-2), only those taxa with reduced or absent wings will be
displayed.
Many characters in a matrix were included simply to distinguish one taxon. These were
generally not informative, or even not applicable, to other taxa. In such cases these cells were
coded with a U, which can also mean unknown. For example, wing characters are not applicable
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to taxa with reduced wings. In INTKEY, when a wing venation character is used, this character
does not affect taxa with a U coded for the character.
The intended audience for the Hymenopteran Interactive Key is wide: high school
teachers, undergraduates, amateur entomologists, graduate students in insect taxonomy, and
professional taxonomists researching Hymenoptera. In order to increase the potential for diverse
interests groups to use the key, terminology was standardized across families; characters were
worded in complete sentences and the use of technical language was minimized. Wing
terminology, reinvented by many authors, was standardized from Sharkey and Wharton (1997).
The interpretation of technical language may be a great obstacle for a novice key user (Jarvie &
Stevens, 1998). A term such as “torulus” was changed to the vernacular “antennal insertion” and
“seta” was changed to “hair.” Also, each of the keys was linked to a glossary of Hymenoptera
terminology.
Collaborator Involvement
The initial matrix mimicked the characters in the dichotomous keys found in
Hymenoptera of the World: an Identification Guide to Families. The matrix was coded by
extrapolating from the dichotomous key which was then sent to collaborators specializing in
particular families. Specialists were asked to review the characters and character state codings,
code the parts of the matrix that could not be extrapolated from the dichotomous key, and send
specimens for photography. The list of collaborators includes: Matthew Buffington at the
University of California Riverside (Cynipoidea), Jim Carpenter at the American Museum of
Natural History (Vespoidea), Andrew Deans at the University of Illinois (Evanioidea), Lynn
Kimsey at University of California Davis (Chrysidoidea), Lubomir Masner at the Canadian
National Collection of Insects (Proctotrupoidea and Platygastroidea), Michael Ohl at Museum
fur Naturkunde der Humbolt-Universitat (Apoidea), Laurence Packer at York University
(Apoidea), Jean-Yves Rasplus at Campus International de Baillarguet (Chalcidoidea), Susanne
Schulmeister at the American Museum of Natural History (Symphyta), David Smith at the
Smithsonian Institution (Symphyta), Michael Sharkey at the University of Kentucky
(Ichneumonoidea), Lars Vilhelmsen at the Zoological Museum University of Copenhagen
(Symphyta), Matthew Yoder at Texas A&M University (Proctotrupoidea) and David Wahl at the
American Entomological Institute (Ichneumonoidea). Depending upon the preferences of the
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collaborators the files were sent as a Nexus file, DELTA file, Macrosoft Excel© file, Nexus Data
Editor file, Winclada file, or paper copy.
Nexus files were exported directly from the DELTA editor and were imported directly
into either PAUP, Nexus Data Editor or Winclada. The ‘chars’, ‘items’ and ‘specs’ directive
files were translated into Excel© files using Taxisoft©, a data conversion program written by
E.J. Gouda. This is a freeware program available on the internet at the Free Delta website
(http://www.websamba.com/freedelta). The three DELTA files were placed in the same folder
as the 2exl.bat execution file. The “*DATA BUFFER SIZE 4000” line in the ‘specs’ file (figure
2-9) was deleted and the file resaved so the program could run correctly.
Figure 2-9:‘specs’ directive file illustrating input into Taxisoft©
*SHOW ~ Dataset specifications.
*DATA BUFFER SIZE 4000
*NUMBER OF CHARACTERS 25
*MAXIMUM NUMBER OF STATES 6
*MAXIMUM NUMBER OF ITEMS 11
*CHARACTER TYPES 15,IN
*NUMBERS OF STATES 10,6
*IMPLICIT VALUES
*DEPENDENT CHARACTERS 16,2:17
*MANDATORY CHARACTERS
The translation into tab-delimitated text occurred when the ‘2exl.bat’ execution file was double
clicked and the ‘itemtab.txt’ file was opened in Excel©. When opening the ‘itemtab.txt’ the
option “read the ‘.txt’ characters only as text” was preferred, because otherwise some of the
characters contained within the ‘items’ file may have been read as calendar dates.
Adding Notes and Text to DELTA
Supportive information was added to INTKEY from DELTA. From the Character
Editor window, notes were entered in the field that comes up after selecting the Notes tab. Text
was typed directly into the field or pasted from a text editing program such as Notepad© or
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Microsoft Word©. Terms defined within the Edit character notes field were underlined using
the text edit button. After the Notes field was complete, the Done button closed the window.
Figure 2-10: Edit character notes tab from Character Edit window in DELTA

The Edit character notes field in DELTA (figure 2-10) was particularly useful for explaining
exceptional character states or unusual terminology because the data entered in this field was
translated into an INTKEY Notes buttons. These buttons appear in INTKEY on the same
window as the character state illustrations (figure 3-3).
Image Editor and Overlays
Prepared character images were inserted into DELTA from the Image tab on the
Character Edit window (figure 2-11). The same actions were used for importing a taxon image
into DELTA, except that the taxon image was entered in the Item Edit window, not the
Character Edit window.
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Figure 2-11: Image files tab from Character Edit window in DELTA

Images imported into DELTA are in ‘JPG’, ‘BMP’ or ‘GIF’ formats. The buttons to the
right of the Image files field controls the files within the window. Multiple images may be
added to the DELTA file. The Display button displays the highlighted image, the Delete button
deletes the highlighted image and the Add button adds an additional image. In the Subject Text
field descriptions were written as they appear in INTKEY. This allows the file name to be listed
in a descriptive fashion inside the interactive key. The Settings button opens the Image Settings
window (figure 2-12), which changes the default settings for the images. This panel may also be
opened in the Item Edit window by choosing View> Image settings from the menu or by rightclicking on the image file. It includes the image font settings, the image saving path, the image
overly settings, and the hotspots.
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Figure 2-12: Image Settings window in DELTA

Under the Overlay font settings field the default font was set as Times New Roman for
all text boxes in INTKEY. Changing this setting modifies the image settings throughout the
DELTA file. This is also true for the Image Path field. The Image Path informs the program
of where the image folder is located within the directive file. If this setting is incorrect, the
Image Path will be broken and images will not appear within INTKEY. Changing the default
settings does not affect previously entered text. The OK or Apply button must be pressed for
any changes to be applied.
The default overlay used was a clear rectangle which turns black when selected. The
function of the overlays for character images is to explain the character and character states, add
hotspots for the user to choose which image describes the correct character state, and supply a
section for notes and additional comments.
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Figure 2-13: Overlays in DELTA

The types of overlays supplied by DELTA are dictated by the type of character. If the
image is associated with an unordered multi-state character, as pictured above, two hotspots, OK
button, Cancel button, Notes button and character text are provided. If the character is an
integer, DELTA does not give hotspots as an option. Instead a box for entering a number is
presented. The OK and Cancel buttons are supplied for an image and the Notes button is
supplied only if information is entered in the Notes field of the Character Edit window. All of
the buttons were arranged manually, by moving them around with the mouse. The character text
was resized to fit the individual images and hotspots were dragged and resized over the entire
character state image (figure 2-13). The hotspot area is the part of the image an INTKEY user
may click to making a character state choice.
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When multiple images are present, an INTKEY user may scroll through the images from
the menu, control>next image. Only one image is displayed at a time, so the user was notified of
a second image using an instructional text box on the first image. This was done with a Text
overlay and a statement informing the user that a second image is present. The Item Edit
window has the same image importation and overlay options as the Character Edit window.
Controlling-Attributes and Dependencies
Controlling characters were defined using the Controlling-Attribute window. This
window is found on the Controls tab of the Character Edit window (figure 2-14).
Figure 2-14: Controlling attribute tab from Character Edit window in DELTA

Controlling characters function to render associated characters inapplicable, if they are not useful
after the specific character state has been chosen. This assists the INTKEY user by removing
inapplicable characters that are non-informative for the user’s specimen. For example, “wings
absent” was defined as a controlling attribute for characters that deal with wing venation.
Therefore if an INTKEY user were to choose the character state “wings absent,” the wing
venation characters would be removed from further consideration in the key.
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To create a controlling-attribute, the intended controlling character’s Character Edit
window is opened. In the above example, “wings absent” was defined as the controlling state of
the character “Are the wings fully developed,” so the Controls tab was opened from the
Character Edit window for this character. The character states for the character are listed in the
Defined by states field. When the intended character is double-clicked it turns into bold type and
appears in the Controlling attributes field. After a controlling attribute is defined the characters
it makes inapplicable are defined. The list of characters on the far right of the window consists
of the entire list of characters contained within the key. A chosen character is highlighted and
the

button is clicked. The character will then move into the Makes inapplicable field. It is

possible to have both character states defined as controlling attributes.
Once a character state is defined as a controlling attribute it may be used to control other
characters. This is done in the Controlled by window (figure 2-15).
Figure 2-15: Controlled by tab from Character Edit window in DELTA

Controlling attributes for characters are entered from the Controlled by tab under the character
intended to be affected. A character listed in the Defined controlling attribute field is clicked
followed by the

button; moving the character to the Made inapplicable by field.

Controlled characters are seen in both the Attribute Editor (Grid) and the Attribute Editor
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(Tree) windows as red lines and grayed out boxes. The Edit, Variant, and Language options
found on the Character Edit window are not functional at the present time.
Character dependencies allow for flexibility within the key by creating characters
specifically designed for grouping other characters. For example, in the Apoidea key, the
character “Is your specimen a male or a female,” is obviously not a keying character as states
“male and female” were coded for every taxon. However, many of the characters in the Apoidea
key are sex specific and the use of character dependencies for this character allows the INTKEY
user to remove a large number of characters that do not pertain to the sex of the specimen being
identified.
DELTA files that contain controlling attributes are not exported successfully into other
formats, including NEXUS files. If a DELTA file was intended for use in an interactive key and
as a NEXUS file, it was saved as two files; one with dependencies and controlling attributes for
INTKEY; and one without for NEXUS.
Exporting DELTA Directives to INTKEY
Directives are exported before CONFOR can be used to create an INTKEY. Directives
are exported from the menu, File>Export Directives (figure 2-16).
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Figure 2-16: Select DELTA files to export window

The Select DELTA files to export window allows the author to choose which directives to
export and where to export them. The Change button allows you to change the export location
directives will be exported. It was useful to not export directives (i.e., ‘contents.ind,’
‘toolbar.inp’) that were manually manipulated in Notepad© because the DELTA program default
would overwrite the directives contained within the directive folder. After directives were
exported, CONFOR was used to create INTKEY by operating from the Actions window (figure
2-17). The Actions window was accessed from the menu View>Action Sets, then the option
“translate into INTKEY format” was highlighted in the Confor field and finally the Run button
was clicked. The product was the ‘intkey.ink’ files that are the initialization files for INTKEY
and are the files that a key user must access in order to run the program.
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Figure 2-17: Actions window in DELTA

Creating Buttons: Changing the ‘toolbar.inp’ and ‘Contents.ind’ Directives
Buttons were created to link the Hymenoptera Family Keys to a web-based glossary of
terms found within the key and to an introduction to the key and a list of references. The button
images were created in Adobe Photoshop© at the size of 50 pixels wide by 52 pixels long, which
is the maximum button size. If a button image is larger than 50X52 it will not appear in the
toolbar of the key. Button images were saved as ‘.jpeg’ files in the directives folder. Buttons
were defined in the ‘toolbar.inp’ directive file (figure 2- 18) by using Notepad© to manually add
the new information tags. The text document ‘Intros.jpg’ was defined as the introduction button
and ‘glossary.jpg’ was defined as the glossary button. The command “FILE DISPLAY” was
modified in the ‘toolbar.inp’ directive file linking the Hymenoptera glossary with the
‘glossary.jpg’ button, causing the Hymenoptera glossary to open when the INTKEY user clicks
the glossary button. The “CONTENTS contents.ind” command was written in the ‘toolbar.inp’
directive file to direct the ‘Intros.jpg’ button to open another directive file, the ‘contents.ind’ file
(figure 2-19).
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Figure 2- 18: ‘toolbar.inp’ directive file in DELTA
*COMMENT ~ Intkey toolbar.
*DEFINE BUTTON CLEAR
*DEFINE BUTTON intros.jpg
"CONTENTS contents.ind"
"Introduction and references"
"This button allows you to display an introduction to the package, or a list
of references."
*DEFINE BUTTON SPACE
*DEFINE BUTTON glossary.jpg
"FILE DISPLAY http://www.uky.edu/~mjshar0/glossary/welcome.html"
"glossary"
"This button links you with the Hymenoptera glossary to help with identification
of entomological terms contained in the key"
The ‘contents.ind’ file was modified to link the words “Introduction,” and “References” to the
files ‘intro.rtf’ and ‘references.rtf’ respectfully. These files are Microsoft Word© rich text
format files and were saved in the directives folder.
Figure 2-19: ‘Contents.ind’ directive file in DELTA
Introduction *FILE DISPLAY intro.rtf
References *FILE DISPLAY references.rtf
The ‘intro.rtf’ files were written as introductory documents for each of the Hymenoptera
Interactive Keys, listing collaborators, special instructions, and acknowledgements. The
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‘references.rtf’ files were customized depending on the key, listing references that pertain to that
particular key.
Linking to Other Interactive Keys: Changing the ‘tlinks’ Directive
A ‘tlinks’ directive file (figure 2-20) links one key to another key.
Figure 2-20: ‘tlinks’ directive file in DELTA
*TAXON LINKS
# most Cynipoidea/
http://www.uky.edu/~mjshar0/datasets/cynip.ink <@subject Interactive Key to the
Cynipoidea Families>
The ‘tlinks’ file was modified to create a Taxon Information window in INTKEY, which
appears after double clicking on a taxon name (figure 3-5). Web link options including
species pages, databases, and other keys were linked from the Taxon Information window. In
the superfamily key, taxon names link the superfamily key to the individual family level keys.
For example, the taxon “most Cynipoidea” was linked in the superfamily key to the Cynipoidea
INTKEY (figure 2-20). The command “<@subject Interactive Key to the Cynipoidea
Families>” appears as “Interactive Key to the Cynipoidea Families” in the Taxon Information
window, and “http://www.uky.edu/~mjshar0/datasets/cynip.ink” links the text to the ‘cynip.ink’
file, which is the Cynipoidea interactive key.
Pop-up Introductory Image: the ‘toint’ Directive
A representative image introducing each key was created to open before the user is
allowed to view the interactive key. The image contains a pictorial example of a taxon contained
within the key, and author acknowledgements. These images were edited in Adobe Photoshop©
and saved in the images file as ‘title.jpg’. The pop-ups were linked to the interactive key either
with the Action-Sets window or with the ‘toint’ file. Below is a portion of a ‘toint’ file (figure
2-21).
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Figure 2-21:‘toint’ directive file in DELTA
*INPUT FILE cnotes
*INPUT FILE ofonts
*INPUT FILE cimages
*INPUT FILE timages
*STARTUP IMAGES
title.jpg
*COMMENT If you want Intkey to link to descriptions generated by 'tonatsr',
activate the following directive. Before running this file (toint), you must
modify 'ofiles', and make additions to your data as described in 'ofiles'.
*COMMENT : INPUT FILE ofiles
The command “STARTUP IMAGES ‘title.jpg’” was added to the ‘toint file’ with Notepad© and
imported back into DELTA using the menu, file> import directives. The Import File window
opens and functions similarly to the Export File window. Only the ‘tokey’ directive file was
imported to incorporate the pop-up into INTKEY. A second way to change the ‘toint’ file is in
the Action-Sets window. From the menu, View>Action Sets opens the Action-Sets window,
“translate into INTKEY format is highlighted” and the Edit button is clicked. The line
*STARTUP IMAGES ‘title.jpg’ is added to the file and the window is closed. The DELTA file
must then be saved for the changes to be incorporated.
Interactive Keys on the Internet: the Intkey.ink File
The ‘intkey.ink’ file (figure 2-22) was written to point the browser to the location where
the information for the key is stored on the web and specifies the image path for the images
associated with the key. It opens INTKEY from the html link on the ‘welcome.index’ web page
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for the Hymenoptera Interactive Keys. All of the directives, except the ‘intkey.ink’ file, are kept
in a zip file and the images are contained in a folder with the same name.
Figure 2-22:‘Intkey.ink’ directive file in DELTA
InkFile=http://www.uky.edu/~mjshar0/datasets/cynip.ink ; Name of this file
InitializationFile=intkey.ink ; Name of the Intkey initialization file within the compressed data
file
DataFile=http://www.uky.edu/~mjshar0/datasets/cynip.zip ; Name of the compressed data set
ImagePath=http://www.uky.edu/~mjshar0/datasets/cynip ; Image path
These ‘intkey.ink’ files were named after the key with which they are associated. For example,
the key to the Cynipoidea ‘intkey.ink’ file was renamed the ‘cynip.ink’, thus distinguishing it
from the Evanioidea ‘intkey.ink’ file, ‘Evan.ink’. This renaming allowed multiple ‘intkey.ink’
files to exist in the same folder on the web. All of the files related to the interactive keys are
found on the web in one folder, the datasets folder (ftp://www.uky.edu/www/datasets/).
Photography: Creating Images for INTKEY
The quality of photographs, illustrating the taxa, characters and character states, was an
important consideration before taking the approximately 600 photographs needed for the
Interactive Key to the Hymenopteran Families. Every preparation, from cleaning the specimen
to incorporating the image into the key, took approximately three hours. Efforts were made to
increase efficiency and streamline the photographic process.
Specimen Preparation
Fresh specimens were used whenever possible to lessen contamination from particulates
that collect on older specimens. However, when fresh specimens were not available, older
specimens were initially cleaned using an insect pin briefly rubbed on fabric. Dust, moth scales
and paper fibers which were attached to the insect jump to the statically charged pin tip as it
nears the specimen. If an unwanted particle was difficult to remove, a small amount of insect
shellac was placed on the pin tip and was touched to the particle. Specimens were relaxed using
a technique developed by Carlos Sarmiento-Monroy (personal communication), in which the
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specimen is exposed to warm, moist air until the specimen is soft enough to move into a desired
position. Larger specimens required more time than smaller ones. Dissections were slide
mounted using glycerol and a cover slip just prior to photography. Mouthpart and genitalic
dissections were cleared using 10% KOH for one hour (Packer, 2003) and were stored in
glycerol. Wings were remounted on white label paper and repined with the original specimen.
Lighting Techniques and Auto-montage
The majority of the interactive key photographs were taken with a JVC© digital camera,
model number KY-F75U, attached to a MJZ 16 Leica© microscope. The camera was connected
with a firewire cable to an IBM Pentium 4 Intellistation MPro PC running WindowsXP.
Software and hardware developed by Syncroscopy© were used to generate auto-montaged
images. Intact specimens were placed on a block of neutral grey modeling clay on Kodak©
neutral grey card in preparation for photography. The 14% neutral grey is useful in maintaining
the color of the specimen and reducing the amount of reflectivity of the surface (Stephen
McJonathan, personal communication) and the modeling clay allows for 180 degree
manipulation of the specimen. Fresh specimens were pinned on neutral grey archival paper
points. Lights were adjusted differently depending upon the area of the specimen which needed
to be photographed. Generally, light was produced from two fiber optic cables positioned on
either side, and slightly above, the specimen with a series of Styrofoam© cups between the light
source and the specimen (figure 2-23). The cups diffused light and reduced glare. One cup was
placed directly around the specimen and two other Styrofoam© cup segments were placed close
to the light source.
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Figure 2-23: Auto-montage lighting

Light from surrounding sources was minimized by pulling the blinds and turning off the
fluorescent lights in the room. With the fluorescent lights on the images were tinted in an unnatural
blue and possessed unwanted glare. Slide-mounts were placed on two petri-dishes, raising the
slide above the microscope stage. Light produced from the microscope base and light from the
fiber-optic cables was reduced to a very low level (setting one or two). Styrofoam© cups were
not used to diffuse the light; however, it was essential that the room was otherwise dark.
Auto-montage is the process of taking multiple photographs each at a different focal
length, removing all of the elements of each photograph that are not in focus, and putting the
parts that are in focus into a single image. Syncroscopy© Auto-montage software performs this
process automatically. Once the specimen was positioned in the camera’s view, a number of
choices were made which affected the final product. The camera shutter speed was set at two to
four seconds. A slow shutter speed correlates with an increase in the exposure time for each
photograph, resulting in an increased amount of light allowed into the camera. A slow shutter
speed allows for the use of less light thus reducing glare. One disadvantage of using a slow
shutter speed is it decreases the image contrast, or the tonal difference between the strongest
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black in the photograph and the strongest white, and it is important to maintain strong contrast
when emphasizing cuticle sculpture.
A second variable was the number of photographs taken in the auto-montage process. As
a general rule, twenty-five photographs were used for the images within the key. Variation did
occur when photographing relatively flat objects, or when large objects were photographed.
Each photograph takes time, so reducing the amount of photographs was important in increasing
efficiency. For flat objects, the minimal number of images was taken. Label information was
photographed with one or two photos and slide mounted specimens with five photographs. In
contrast, large specimens often required thirty or more images to produce a well montaged final
image.
Editing Photographs in Adobe Photoshop©
Using a neutral grey background, diffuse lighting, and slow shutter speeds produce
adequate photographs for the majority of the specimens and characters. However, the images
tend to be high in detail but low in contrast with distracting, jumbled backgrounds. The most
difficult specimens to photograph are small, black, and shiny, or yellow with a transparent
exocuticle. In both of these special cases the post production process is important as the
specimen image itself may be jumbled because the auto-montage software has difficulty
correctly identifying what part of the specimen is in focus. All of these imaging problems: low
contrast, distracting background, and jumbled pixels were corrected in Adobe Photoshop© prior
to incorporating the images into the interactive key. Examples of images before and after editing
show the improvements (figure 2-24, 2-25). Again this process was standardized during the
creation of the Hymenoptera Family Key to reduce the amount of time allotted to each successful
image.
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Figure 2-24A: Images before and after post production techniques

before

after

Figure 2-24B: Images before and after post production techniques

Before

after

Initially the background was selected using the magic wand tool at a tolerance set at 10,
anti-aliased and contiguous. A higher tolerance tends to select into the specimen image, and a
tolerance at less than 10 selects only a few pixels at a time. Once the majority of the background
is selected corrections were done using the lasso tool. The image edge was observed at 200%,
looking for areas where the magic wand did not select close enough to the specimen or where it
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selected part of the specimen instead of the background. Wings are often critical areas for close
examination of the magic wand selection.
Once the entire background was selected the contrast is removed from the background,
which is then darkened slightly. From the Adobe Photoshop© menu
Image>Adjustments>Brightness/Contrast, option was chosen and a sliding control bar appeared.
The Contrast sliding bar was moved to the -100 position. The brightness bar was moved from a
central 0 to between -10 and -2. After the background was removed the Gaussian blur filter was
applied to the background from the menu Filter>Blur>Gaussian Blur. The blur radius was set at
3.1, which was generally sufficient. Hairy specimens, such as many Apoidea and Vespoidea,
required a lower radius setting of 2.0.
The specimen image was then selected from the menu ‘Select>Inverse’ and its contrast
increased from the menu Image>Adjustments>Auto Contrast. The entire image was then
deselected from the menu Select>Deselect. At this point specific corrections were made on the
specimen image using the Clone Stamp Tool. This tool allows an area of pixels to be sampled
and then replace pixels in another area. It was useful in covering areas of the specimen image
that were distorted during the process of auto-montage or removing dust particulates (figure 226). The brush size was most effective when it was set at a small size of around 4 pixels.
Figure 2-25: Clone stamp tool

Before

after

A number of the Symphyta, Proctotrupoidea and Apoidea were too large in size to
photograph with a single photo. These specimens were spliced together manually after
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photographing all of the different areas of the specimen (figure 2-27). After the specimen is
reconnected in Photoshop© the same editing protocol was used as for the smaller specimens.
Figure 2-26: Process of reconnecting a large specimen

For wing photographs color was removed and the contrast was increased to emphasize
the wing venation. Color was removed by desaturating the image, not changing the mode from
RGB to Greyscale, because a Greyscale image becomes incompatible with a RGB or color image
document. To desaturate an image from the menu choose Image>Adjustments>Desaturate.
Contrast is increased after desaturation, and the background of wing images is often removed to
a very light grey in order to emphasize the wing shape.
Images used to illustrate characters and taxa were set at approximately 760 pixels X
527-560 pixels; the maximum size image that could fit in its entirety on a mid-size monitor.
Character state images were placed in a single Photoshop© document of that size and arranged
on the page so they were easily viewed and the overlays were easily placed on top of the images.
During this process the images were often reduced in size. The original corrected image was
saved as a Photoshop©, ‘.psd),’ document in a separate folder to archive the original pixel
information. The colors used for the arrows, background and text were standardized in the
Hymenoptera Family Key using the ANAP color system for illustrations and graphics. The
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background color for character images was ANPA 737-6 AdPro, text/arrows were ANPA 755-O
AdPro or true black. This color system was chosen for its availability in Adobe Photoshop© and
its intended use for images on computer screens. The background blue/green color was chosen
to increase the keys visual appeal (Hall & Hanna, 2004).
In conclusion, the primary purpose for creating images for INTKEY is to illustrate taxa
and characters. Although the photographic guidelines described here were maintained to
increase efficiency in the photographic process, they were manipulated on an individual
photograph basis to increase image quality and effectiveness in the Hymenoptera Interactive
Key. Each image must illustrate the character in the described state in order to be informative.
Ideally, images illustrating character states should illustrate not only the most obvious examples
of that state, but also the intermediate conditions. Sometimes photographs, although generally
the preferred illustrative method for the Hymenoptera Key to Families Project were used. This
occurred when a character is difficult to photograph, or an appropriate specimen is not available.
In these circumstances drawings are used from the Henri Goulet and John Huber text,
Hymenoptera of the World: An Identification Guide to Families.
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Chapter III: Results

Interactive Key Example
The project resulted in a series of Hymenoptera Interactive Keys using the INTKEY
program written by (Dallwitz et al., 1993). The keys contain 145 taxonomic divisions, 286
characters, 600 photographs, and 40 line drawings. The line drawings, primarily drawn by S.
Rigby, come from Hymenoptera of the World: an Identification Guide to Families. Scanning
electron microscope images are from Matt Buffington and Fredrik Ronquist. The keys are an
expandable and easily updatable foundation for more detailed keys to the order; thus, the
majority of the information found within the keys is attached in matrix form at the end of the
document.
An INTKEY example of the superfamily Proctotrupoidea is attached as an ‘Intkey.ink’
file and as a series of screen shots with descriptions of the keys function. The key is intended to
illustrate the program not as a final product. In order to view the key a small program must be
installed on a computer running Windows 95 thru Windows XP. The program may be obtained
here. Save the ‘.exe file’ to your computer’s desktop, double click on the ‘intkey.exe’ file and
follow the installation instructions. It may be necessary to restart the computer before INTKEY
can run properly. Once the INTKEY program is installed on the computer any INTKEY
interactive keys may run from that machine. The example INTKEY to the Proctotrupoidea is
found here. The key will open automatically in the Web browser.
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The Interactive Key to the Proctotrupoidea begins with a splash page that introduces the key.
Figure 3-1: Hymenoptera Interactive Keys; Proctotrupoidea splash page
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Figure 3-2: Hymenoptera Interactive Keys; Proctotrupoidea opening page

After the initial splash page, a typical INTKEY window opens, with a list of characters on the
top left column and a list of taxa on the top right column (figure 3-2). This window opens with
the characters listed in the Best Order. This ranks the characters based on their effectiveness in
keying taxa. The two large buttons at the top left are linking buttons for the Contents files and
the Hymenoptera Glossary. The Contents text file lists the introduction, acknowledgements, and
references for the particular interactive key. The Hymenopteran Glossary button is a web link to
the Hymenopteran Glossary. These buttons are modified in the Hymenoptera Interactive Keys
using the ‘toolbar. Imp’ directive file in DELTA. The Hymenopteran Glossary is derived from
the glossary contained within the text Hymenoptera of the World: an Identification Guide to
Families, edited by Michael J. Sharkey and John Huber. The reproduced drawings of key terms
are also taken from this text.
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Figure 3-3: Hymenoptera Interactive Keys; Proctotrupoidea INTKEY integer character

When the character “How many flagellomeres does the antenna have?” is double clicked,
the associated image file is retrieved from the image folder on the web (figure 3-3). Overlays
associated with the character are a text box for entering the number of flagellomeres, a character
description and explanatory text boxes describing what is required of the user.
The number of flagellomeres of the user’s specimen is entered in the cell and the OK button is
pressed, eliminating all of the taxa outside of that range.
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Figure 3-4: Hymenoptera Interactive Keys; Proctotrupoidea INTKEY after the selection of
character “How many flagellomeres does the antenna have?”

The Used Characters are listed on the bottom left of the screen and the Eliminated Taxa are
listed on the bottom right column of the screen (figure 3-4). The user may change their mind
about character choice at any time during the keying process by double clicking a used character
and modifying the character state choice.
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Figure 3-5: Hymenoptera Interactive Keys; Proctotrupoidea INTKEY comparison of taxa by
double clicking the taxon name

Taxon images are double clicked to show associated images. At any time during the
keying process the user may compare habitus images of taxa (figure 3-5). Multiple images may
be entered in the habitus window for to facilitate the comparison of taxa.
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Figure 3-6: Hymenoptera Interactive Keys; Proctotrupoidea INTKEY unordered multistate
character

Any character may be clicked in the list of characters, allowing the user to choose
characters specifically for the specimen they intend to identify. For example, an unusual
morphological character such as a strong antennal shelf quickly keys a specimen to Diapriidae
(figure 3-6) immediately. This is an example of an unordered multistate character, which gives
the user discrete choices. The specimen may have an antennal shelf or not. When the character
state “yes” is chosen, the yes tab becomes black, indicating to the user which choice he/she has
selected.
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Figure 3-7: Hymenoptera Interactive Keys; Proctotrupoidea INTKEY complete identification

When identification is reached (figure 3-7) only one taxon will remain in the Remaining Taxa
field and a help button appears in the Best Characters field. The numbers beside the eliminated
taxa represent the number of times the user chose a character that eliminates that taxon. The
higher the number, the more confidence the user may have of a correct identification of the
specimen. Again, the identified taxon habitus images may then be viewed by double clicking the
taxon name, and these images compared to the specimen the user wishes to identify.
Difficulties and Key Challenges
The Hymenoptera Family Keys are at varying levels of quality because of differences in
collaborator involvement, specimen availability, inherent difficulty of the superfamily, and time
constraints. The keys with strong collaborator involvement tend to be better. These include the
family level keys: Proctotrupoidea, Chrysidoidea, and Symphyta. Keys without strong
collaborator involvement, such as the superfamily key, are less efficient because the matrix is not
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as complete, and the user will usually be required to go through a greater number of characters to
reach identification than would be the case if the matrix were complete. Coding characters for
the entire family was difficult because of the great variation among many of the families; thus,
characters were not coded for families if there was low confidence in character state choice for
that family. Some taxa and characters are not illustrated due to unavailability of specimens.
Keys have been modified from their original dichotomous keys to varying degrees. The
Superfamily Key, Platygastroidea, and Ichneumonoidea remain closest to the original
dichotomous key source material, as most of the characters, character states and taxonomic
divisions remain unchanged. The keys have varying levels of probable success for reaching a
correct identification for a specimen. The Chrysidoidea, Symphyta, Proctotrupoidea,
Ceraphronoidea, Evanioidea and Platygastroidea keys are successful under preliminary trials
with unknown specimens; however, they have not been extensively tested The Apoidea key is
the most inefficient of the keys due to the uncertain phylogeny of the superfamily and a high
degree of convergence in various families, for example, many of the external keying characters
for the families Megachilidae and Apidae are lost in the cleptoparasitic family members
(Michener, 2000), resulting in a great number of exceptions to each family. These exceptions are
separated in the key primarily using mouthpart morphology.
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Chapter IV: Future Prospects and Considerations

Summary of Future Prospects
The Interactive Key to the Hymenopteran Families is intended as an initial effort to
construct an interactive key to the families of the order based on the current phylogenetic
hypotheses. The keys will be integrated into the Hymenoptera Assembling the Tree of Life
Project (HymAToL), supported by the National Science Foundation. The HymAToL project
intends to continue updating and improving the keys based on explorations into the phylogeny of
the order, and will ultimately include an interactive key to the families of the Chalcidoidea. The
level of detail within the keys will be improved by including more images illustrating the
taxonomic diversity, using specific names for taxon images, adding detailed notes and character
images associated with problematic character states, and images illustrating exceptional taxa. As
part of ongoing collaboration among Hymenopterists, the keys will link at the family level to
existing keys to genera, web sites of researchers actively investigating a taxon, and species
pages.

The image files associated with the key will be uploaded to an online image database

where they will be available to the public. Morphbank (http://www.morphbank.org) is a primary
consideration due to its use in the HymAToL project. The public availability of the keys will be
announced at professional meetings and through list-servs such as ENTO-L and TAXICOM.
Presently the interactive keys require the installation of the program INTKEY on the
user’s computer in order to view the keys, potentially limiting public access. Commonwealth
Scientific and Industrial Research Organization (CSIRO) plans to release a web-native version of
INTKEY (Steve Shattuck, personal communication) and the prospect of transferring the
interactive keys will be evaluated at that time. Eventually the use of online image databases,
such as Morphbank, may replace much of our need for printed material and will connect files
directly from these databases to interactive keys for use by researchers, educators and
entomological enthusiasts.
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Chapter V: DELTA Matrices
The matrices are in Excel© format. The taxa are linked to habitus illustrations found
within the key. If multiple habitus images exist for a taxon, the link corresponds to the first
image on the list. Characters are listed in the matrices by consecutive numbers: 1, 2, 3. etc.
These numbers are linked to the character description and character states as generated by the
DELTA chars file. Character state images and taxon images, if present, open in a new window
and can be closed by closing the browser window.

The matrices are:
Apoidea
Ceraphronoidea
Chrysidoidea
Cynipoidea
Evanioidea
Ichneumonoidea
Platygastroidea
Proctotrupoidea
Superfamily
Symphyta
Vespoidea
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